Naming things is hard, really hard and if done poorly it can make your code really confusing and hard to follow. Typically you want them to avoid having function named as nouns. Choose to name them as verbs. Because they are usually doing something. Much like the great early 00’s commercials of “Verb: It’s what you do.”
- Have function names that are unique
- Go over naming conventions with other developers.
- Always come back to “What is this function doing?”
- Be consistent in your naming conventions.
- Break up the function so its only doing one thing. If it does more than one thing then it’s probably a good idea to extrapolate it.
Some helpful tips I’ve been given
A common approach is either
GetSomethingBySomething(string something) or